|
@@ -0,0 +1,48 @@
|
|
|
+Description: Updated intltoolize
|
|
|
+ Execute "intltoolize -f -c" to update Makefile.in.in
|
|
|
+---
|
|
|
+Origin: Adrian Bunk <[email protected]>>
|
|
|
+Bug-Debian: https://bugs.debian.org/858567
|
|
|
+Last-Update: 2017-03-31
|
|
|
+
|
|
|
+--- mssh-2.2.orig/po/Makefile.in.in
|
|
|
++++ mssh-2.2/po/Makefile.in.in
|
|
|
+@@ -33,8 +33,7 @@ exec_prefix = @exec_prefix@
|
|
|
+ datadir = @datadir@
|
|
|
+ datarootdir = @datarootdir@
|
|
|
+ libdir = @libdir@
|
|
|
+-DATADIRNAME = @DATADIRNAME@
|
|
|
+-itlocaledir = $(prefix)/$(DATADIRNAME)/locale
|
|
|
++localedir = @localedir@
|
|
|
+ subdir = po
|
|
|
+ install_sh = @install_sh@
|
|
|
+ # Automake >= 1.8 provides @mkdir_p@.
|
|
|
+@@ -80,7 +79,7 @@ INTLTOOL__v_MSGFMT_0 = @echo " MSGFMT"
|
|
|
+
|
|
|
+ .po.pox:
|
|
|
+ $(MAKE) $(GETTEXT_PACKAGE).pot
|
|
|
+- $(MSGMERGE) $< $(GETTEXT_PACKAGE).pot -o $*.pox
|
|
|
++ $(MSGMERGE) $* $(GETTEXT_PACKAGE).pot -o $*.pox
|
|
|
+
|
|
|
+ .po.mo:
|
|
|
+ $(INTLTOOL_V_MSGFMT)$(MSGFMT) -o $@ $<
|
|
|
+@@ -108,7 +107,7 @@ install-data-no: all
|
|
|
+ install-data-yes: all
|
|
|
+ linguas="$(USE_LINGUAS)"; \
|
|
|
+ for lang in $$linguas; do \
|
|
|
+- dir=$(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES; \
|
|
|
++ dir=$(DESTDIR)$(localedir)/$$lang/LC_MESSAGES; \
|
|
|
+ $(mkdir_p) $$dir; \
|
|
|
+ if test -r $$lang.gmo; then \
|
|
|
+ $(INSTALL_DATA) $$lang.gmo $$dir/$(GETTEXT_PACKAGE).mo; \
|
|
|
+@@ -142,8 +141,8 @@ install-exec installcheck:
|
|
|
+ uninstall:
|
|
|
+ linguas="$(USE_LINGUAS)"; \
|
|
|
+ for lang in $$linguas; do \
|
|
|
+- rm -f $(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo; \
|
|
|
+- rm -f $(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo.m; \
|
|
|
++ rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo; \
|
|
|
++ rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo.m; \
|
|
|
+ done
|
|
|
+
|
|
|
+ check: all $(GETTEXT_PACKAGE).pot
|