1
0
Преглед на файлове

Imported Debian patch 1.2-1.1

gregor herrmann преди 12 години
родител
ревизия
51832c74b6
променени са 2 файла, в които са добавени 25 реда и са изтрити 2 реда
  1. 14 0
      debian/changelog
  2. 11 2
      src/mssh-terminal.c

+ 14 - 0
debian/changelog

@@ -1,3 +1,17 @@
+mssh (1.2-1.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * Fix "FTBFS: mssh-terminal.c:49:5: error: 'vte_terminal_fork_command'
+    is deprecated (declared at /usr/include/vte-
+    0.0/vte/vtedeprecated.h:82) [-Werror=deprecated-declarations]":
+    apply patch from Ubuntu / Michael Vogt:
+    - fix ftbfs (LP: #756105)
+    (use vte_terminal_fork_command_full instead of the deprecated
+    vte_terminal_fork_command in src/mssh-terminal.c)
+    (Closes: #634426)
+
+ -- gregor herrmann <[email protected]>  Wed, 02 Nov 2011 19:32:56 +0100
+
 mssh (1.2-1) unstable; urgency=low
 
   * New upstream release.

+ 11 - 2
src/mssh-terminal.c

@@ -40,14 +40,23 @@ void mssh_terminal_init_session(MSSHTerminal *terminal, char *hostname)
 
 void mssh_terminal_start_session(MSSHTerminal *terminal, char **env)
 {
+    GError *error = NULL;
     char *args[3];
 
     args[0] = strdup("ssh");
     args[1] = terminal->hostname;
     args[2] = NULL;
 
-    vte_terminal_fork_command(VTE_TERMINAL(terminal), "ssh", args,
-        env, NULL, FALSE, FALSE, FALSE);
+    vte_terminal_fork_command_full(VTE_TERMINAL(terminal), 
+                                   VTE_PTY_NO_LASTLOG|VTE_PTY_NO_UTMP|VTE_PTY_NO_WTMP,
+                                   NULL,  /* working dir */
+                                   args,
+                                   env, 
+                                   G_SPAWN_SEARCH_PATH,
+                                   NULL,  /* child_setup */
+                                   NULL,  /* child_setup_data */
+                                   NULL,  /* *child_pid */
+                                   &error);
 
     free(args[0]);
 }