Browse Source

Initial commit.

Signed-off-by: Bradley Smith <[email protected]>
Bradley Smith 14 years ago
parent
commit
a6887c4366
9 changed files with 172 additions and 0 deletions
  1. 5 0
      debian/changelog
  2. 1 0
      debian/compat
  3. 17 0
      debian/control
  4. 56 0
      debian/copyright
  5. 26 0
      debian/mssh.1
  6. 1 0
      debian/mssh.install
  7. 1 0
      debian/mssh.manpages
  8. 63 0
      debian/rules
  9. 2 0
      debian/watch

+ 5 - 0
debian/changelog

@@ -0,0 +1,5 @@
+mssh (0.1-1) unstable; urgency=low
+
+  * Initial release. Closes: #539660.
+
+ -- Bradley Smith <[email protected]>  Sun, 02 Aug 2009 19:11:20 +0100

+ 1 - 0
debian/compat

@@ -0,0 +1 @@
+7

+ 17 - 0
debian/control

@@ -0,0 +1,17 @@
+Source: mssh
+Section: admin
+Priority: optional
+Maintainer: Bradley Smith <[email protected]>
+Build-Depends: debhelper (>= 7), libgtk2.0-dev, libvte-dev
+Standards-Version: 3.8.2
+Homepage: http://brad-smith.co.uk/
+
+Package: mssh
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, openssh-client
+Description: tool to administrate multiple servers at once
+ MultiSSH is a GTK+ based SSH client designed to connect to multiple
+ servers and issue to same commands to each server, making administering
+ multiple servers less of a chore. There is also functionality to only
+ issue commands to individual servers, and to select a portion of the
+ servers to send commands to.

+ 56 - 0
debian/copyright

@@ -0,0 +1,56 @@
+Author: Bradley Smith <[email protected]>
+Download: http://ftp.brad-smith.co.uk/mssh/
+
+Files: *
+Copyright: (C) 2009 Bradley Smith <[email protected]>
+License: BSD
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions are
+ met:
+
+    1. Redistributions of source code must retain the copyright notice,
+       this list of conditions and the following disclaimer.
+    2. Redistributions in binary form must reproduce the copyright notice,
+       this list of conditions and the following disclaimer in the
+       documentation and/or other materials provided with the distribution.
+    3. The name of the author may not be used to endorse or promote
+       products derived from this software without specific prior written
+       permission.
+
+ THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+ IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+ OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN
+ NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+ TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+ PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+ LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+ NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+Files: debian/*
+Copyright: (C) 2009 Bradley Smith <[email protected]>
+License: BSD
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions are
+ met:
+
+    1. Redistributions of source code must retain the copyright notice,
+       this list of conditions and the following disclaimer.
+    2. Redistributions in binary form must reproduce the copyright notice,
+       this list of conditions and the following disclaimer in the
+       documentation and/or other materials provided with the distribution.
+    3. The name of the author may not be used to endorse or promote
+       products derived from this software without specific prior written
+       permission.
+
+ THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+ IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+ OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN
+ NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+ TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+ PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+ LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+ NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

+ 26 - 0
debian/mssh.1

@@ -0,0 +1,26 @@
+.TH MSSH 1
+.SH NAME
+mssh \- tool to administrate multiple servers at once
+.SH SYNOPSIS
+.B mssh
+[\fIOPTION\fR]... [\fIHOSTS\fR]
+.SH DESCRIPTION
+.B MultiSSH
+is a GTK+ based ssh client to issue the same commands to multiple servers.
+
+.B MultiSSH
+will connect to the servers specified in \fIHOSTS\fR.
+.SH OPTIONS
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+Display this help and exit
+.TP
+\fB\-V\fR, \fB\-\-version\fR
+Output version information and exit
+.SH AUTHOR
+.B MultiSSH
+was written by Bradley Smith <brad@brad\-smith.co.uk>
+.SH COPYRIGHT
+Copyright (C) 2009 Bradley Smith <brad@brad\-smith.co.uk>
+.SH REPORTING BUGS
+Report bugs to <brad@brad\-smith.co.uk>.

+ 1 - 0
debian/mssh.install

@@ -0,0 +1 @@
+usr/bin/mssh

+ 1 - 0
debian/mssh.manpages

@@ -0,0 +1 @@
+debian/mssh.1

+ 63 - 0
debian/rules

@@ -0,0 +1,63 @@
+#!/usr/bin/make -f
+
+DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+CFLAGS = -O2 -Wall
+LDFLAGS = -Wl,--as-needed
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+    CFLAGS += -O0
+else
+    CFLAGS += -O2
+endif
+
+configure: configure-stamp
+configure-stamp:
+	dh_testdir
+	LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)" ./configure \
+		--build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE) \
+		--prefix=/usr --mandir=\$${prefix}/share/man \
+		--infodir=\$${prefix}/share/info
+	touch $@
+
+build: build-stamp
+build-stamp: configure
+	dh_testdir
+	$(MAKE)
+	touch $@
+
+clean:
+	dh_testdir
+	dh_testroot
+	rm -f build-stamp configure-stamp
+	[ ! -f Makefile ] || $(MAKE) distclean
+	dh_clean
+
+install: build
+	dh_testdir
+	dh_testroot
+	dh_prep
+	$(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+	dh_install --fail-missing
+
+binary-indep: install
+
+binary-arch: install
+	dh_testdir
+	dh_testroot
+	dh_installchangelogs ChangeLog
+	dh_installdocs
+	dh_installman
+	dh_link
+	dh_strip
+	dh_compress
+	dh_fixperms
+	dh_installdeb
+	dh_shlibdeps
+	dh_gencontrol
+	dh_md5sums
+	dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install

+ 2 - 0
debian/watch

@@ -0,0 +1,2 @@
+version=3
+http://ftp.brad-smith.co.uk/mssh/mssh-([\d\.]+).tar.gz