Browse Source

Switch to dh7 style debian/rules

Bump debhelper compatibility to 9, update debhelper build dependency
Axel Beckert 11 years ago
parent
commit
d8cb8238f3
6 changed files with 12 additions and 70 deletions
  1. 3 1
      debian/changelog
  2. 1 1
      debian/compat
  3. 1 1
      debian/control
  4. 1 0
      debian/mssh.examples
  5. 0 2
      debian/mssh.install
  6. 6 65
      debian/rules

+ 3 - 1
debian/changelog

@@ -1,6 +1,8 @@
 mssh (1.2-3) UNRELEASED; urgency=low
 
-  * Fix lintian warning debian-rules-missing-recommended-target
+  * Switch to dh7 style debian/rules
+    - Bump debhelper compatibility to 9, update debhelper build dependency
+    - Fixes lintian warning debian-rules-missing-recommended-target
   * Switch to source format "3.0 (quilt)"
 
  -- Axel Beckert <[email protected]>  Tue, 01 Jan 2013 16:00:00 +0100

+ 1 - 1
debian/compat

@@ -1 +1 @@
-7
+9

+ 1 - 1
debian/control

@@ -2,7 +2,7 @@ Source: mssh
 Section: admin
 Priority: optional
 Maintainer: Debian QA Group <[email protected]>
-Build-Depends: debhelper (>= 7), libgtk2.0-dev, libvte-dev, libgconf2-dev
+Build-Depends: debhelper (>= 9~), libgtk2.0-dev, libvte-dev, libgconf2-dev
 Standards-Version: 3.8.3
 Homepage: http://brad-smith.co.uk/
 Vcs-Git: git://anonscm.debian.org/collab-maint/pkg-mssh.git

+ 1 - 0
debian/mssh.examples

@@ -0,0 +1 @@
+mssh_clusters.conf

+ 0 - 2
debian/mssh.install

@@ -1,2 +0,0 @@
-usr/bin/mssh
-usr/share/gconf/schemas/mssh.schemas

+ 6 - 65
debian/rules

@@ -1,69 +1,10 @@
 #!/usr/bin/make -f
 
-DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+%:
+	dh $@
 
-CFLAGS = -O2 -Wall
-LDFLAGS = -Wl,--as-needed
+override_dh_auto_configure:
+	dh_auto_configure -- --with-gconf-schema-file-dir=/usr/share/gconf/schemas
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-    CFLAGS += -O0
-else
-    CFLAGS += -O2
-endif
-
-configure: configure-stamp
-configure-stamp:
-	dh_testdir
-	LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)" ./configure \
-		--build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) \
-		--prefix=/usr --mandir=\$${prefix}/share/man \
-		--infodir=\$${prefix}/share/info \
-		--with-gconf-schema-file-dir=/usr/share/gconf/schemas
-	touch $@
-
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-build-stamp: configure
-	dh_testdir
-	$(MAKE)
-	touch $@
-
-clean:
-	dh_testdir
-	dh_testroot
-	rm -f build-stamp configure-stamp
-	[ ! -f Makefile ] || $(MAKE) distclean
-	dh_clean
-
-install: build
-	dh_testdir
-	dh_testroot
-	dh_prep
-	$(MAKE) GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
-		DESTDIR=$(CURDIR)/debian/tmp install
-	dh_install --fail-missing
-
-binary-indep: install
-
-binary-arch: install
-	dh_testdir
-	dh_testroot
-	dh_installchangelogs ChangeLog
-	dh_installexamples mssh_clusters.conf
-	dh_installdocs
-	dh_installman
-	dh_gconf
-	dh_link
-	dh_strip
-	dh_compress
-	dh_fixperms
-	dh_installdeb
-	dh_shlibdeps
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_install:
+	dh_auto_install -- GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1