remove-dash-W-error.patch 1.5 KB

123456789101112131415161718192021222324252627282930313233343536
  1. Description: Remove -pedantic-errors -Werror from CFLAGS
  2. Both, -Werror and -pedantic-errors in CFLAGS are bound to cause FTBFS
  3. quite often, so this patch no more causes warnings to behave as error
  4. by default.
  5. .
  6. Doing this via patch has been chosen over -Wno-error to not undo
  7. dpkg-buildflags' -Werror=format-security.
  8. .
  9. This patch should be removed once the package is no more orphaned
  10. (#674885) and pango's pango-font.h is fixed with regards to #713594.
  11. Author: Axel Beckert <[email protected]>
  12. Debian-Bug: 714438
  13. Index: mssh/src/Makefile.am
  14. ===================================================================
  15. --- mssh.orig/src/Makefile.am 2013-06-23 20:07:02.172028112 +0200
  16. +++ mssh/src/Makefile.am 2013-06-30 11:49:56.299047136 +0200
  17. @@ -1,4 +1,4 @@
  18. -AM_CFLAGS = -pedantic-errors -Werror -Wall -Wfatal-errors -Wwrite-strings
  19. +AM_CFLAGS = -Wall -Wfatal-errors -Wwrite-strings
  20. INCLUDES = $(MSSH_CFLAGS)
  21. Index: mssh/src/Makefile.in
  22. ===================================================================
  23. --- mssh.orig/src/Makefile.in 2013-06-23 20:07:02.176028054 +0200
  24. +++ mssh/src/Makefile.in 2013-06-30 11:50:08.835699354 +0200
  25. @@ -152,7 +152,7 @@
  26. top_build_prefix = @top_build_prefix@
  27. top_builddir = @top_builddir@
  28. top_srcdir = @top_srcdir@
  29. -AM_CFLAGS = -pedantic-errors -Werror -Wall -Wfatal-errors -Wwrite-strings
  30. +AM_CFLAGS = -Wall -Wfatal-errors -Wwrite-strings
  31. INCLUDES = $(MSSH_CFLAGS)
  32. mssh_SOURCES = mssh.c mssh-terminal.c mssh-window.c mssh-pref.c \
  33. mssh-gconf.c