fix-ftbfs-with-libvte-0.50.patch 1005 B

123456789101112131415161718192021222324252627
  1. Description: Fix FTBFS with libvte 0.50 due to deprecated functions
  2. Bug-Debian: https://bugs.debian.org/876685
  3. Author: Axel Beckert <[email protected]>
  4. --- a/src/mssh-terminal.c
  5. +++ b/src/mssh-terminal.c
  6. @@ -67,7 +67,7 @@
  7. args[4] = NULL;
  8. }
  9. - vte_terminal_spawn_sync(VTE_TERMINAL(terminal),
  10. + vte_terminal_spawn_async(VTE_TERMINAL(terminal),
  11. VTE_PTY_NO_LASTLOG|VTE_PTY_NO_UTMP|VTE_PTY_NO_WTMP,
  12. NULL, /* working dir */
  13. args,
  14. @@ -76,8 +76,10 @@
  15. NULL, /* child_setup */
  16. NULL, /* child_setup_data */
  17. NULL, /* *child_pid */
  18. + -1, /* timeout */
  19. NULL, /* *cancellable */
  20. - NULL); /* Error handling */
  21. + NULL, /* callback */
  22. + NULL); /* user_data */
  23. free(args[0]);
  24. }