intltools_update 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. Description: Updated intltoolize
  2. Execute "intltoolize -f -c" to update Makefile.in.in
  3. ---
  4. Origin: Adrian Bunk <[email protected]>>
  5. Bug-Debian: https://bugs.debian.org/858567
  6. Last-Update: 2017-03-31
  7. --- mssh-2.2.orig/po/Makefile.in.in
  8. +++ mssh-2.2/po/Makefile.in.in
  9. @@ -33,8 +33,7 @@ exec_prefix = @exec_prefix@
  10. datadir = @datadir@
  11. datarootdir = @datarootdir@
  12. libdir = @libdir@
  13. -DATADIRNAME = @DATADIRNAME@
  14. -itlocaledir = $(prefix)/$(DATADIRNAME)/locale
  15. +localedir = @localedir@
  16. subdir = po
  17. install_sh = @install_sh@
  18. # Automake >= 1.8 provides @mkdir_p@.
  19. @@ -80,7 +79,7 @@ INTLTOOL__v_MSGFMT_0 = @echo " MSGFMT"
  20. .po.pox:
  21. $(MAKE) $(GETTEXT_PACKAGE).pot
  22. - $(MSGMERGE) $< $(GETTEXT_PACKAGE).pot -o $*.pox
  23. + $(MSGMERGE) $* $(GETTEXT_PACKAGE).pot -o $*.pox
  24. .po.mo:
  25. $(INTLTOOL_V_MSGFMT)$(MSGFMT) -o $@ $<
  26. @@ -108,7 +107,7 @@ install-data-no: all
  27. install-data-yes: all
  28. linguas="$(USE_LINGUAS)"; \
  29. for lang in $$linguas; do \
  30. - dir=$(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES; \
  31. + dir=$(DESTDIR)$(localedir)/$$lang/LC_MESSAGES; \
  32. $(mkdir_p) $$dir; \
  33. if test -r $$lang.gmo; then \
  34. $(INSTALL_DATA) $$lang.gmo $$dir/$(GETTEXT_PACKAGE).mo; \
  35. @@ -142,8 +141,8 @@ install-exec installcheck:
  36. uninstall:
  37. linguas="$(USE_LINGUAS)"; \
  38. for lang in $$linguas; do \
  39. - rm -f $(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo; \
  40. - rm -f $(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo.m; \
  41. + rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo; \
  42. + rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo.m; \
  43. done
  44. check: all $(GETTEXT_PACKAGE).pot